U e5dH�� @s�dZddlZddlZddlmZddlmZmZ m Z ddl Z ddl m Z mZmZddl mZmZmZddl mZmZmZmZmZmZmZddl mZmZdd l mZmZm Z m!Z!zdd l m"Z"Wne#k r�YnXdd l m$Z$m%Z%m&Z&m'Z'm(Z(m)Z)m*Z*m+Z+m,Z,m-Z-dd l m.Z.m/Z/e j0d e1dd�e d�e j0de1dd�e d�e j0de1dd�e d�e j0de1dd�e d�e j0de1dd�e d�e j0de1dd�e d�e2j3Z4e2_4dd�e2j5�6�D�Z7e8e2dd�Z9Gdd�de �Z:Gd d!�d!e �Z;Gd"d#�d#e �Zd&k�r"dd'l m?Z?m@Z@dd(lAmAZAmBZBmCZCmDZDdd)lAmEZEmFZFddlAZGddlHZHddlIZIddlJZJeKZLd*gZMeNe d+�ZOe.ZPeZQd,d-�ZRd.d/�ZSd0d1�ZTd2d3�ZUed4d5�ZVd6d7�ZWGd8d9�d9ed9d:��ZXGd;d<�d�d>e�ZZeYj[fdddd?�d@dA�Z\e3fe]dBeYj[ddddddC�dDdE�Z^e\Z_e^Z`GdFdG�dG�ZadHdI�ZbGdJdK�dKeA�ZceceZ_deaeZ_edddBe]e3ddLdLdf dMdN�ZfdOdP�ZgdQZhdRZidSdT�ZjdUdV�Zke3dfdWdX�ZldYdZ�ZmdS)[a� This module provides some more Pythonic support for SSL. Object types: SSLSocket -- subtype of socket.socket which does SSL over the socket Exceptions: SSLError -- exception raised for I/O errors Functions: cert_time_to_seconds -- convert time string used for certificate notBefore and notAfter functions to integer seconds past the Epoch (the time values returned from time.time()) fetch_server_certificate (HOST, PORT) -- fetch the certificate provided by the server running on HOST at port PORT. No validation of the certificate is performed. Integer constants: SSL_ERROR_ZERO_RETURN SSL_ERROR_WANT_READ SSL_ERROR_WANT_WRITE SSL_ERROR_WANT_X509_LOOKUP SSL_ERROR_SYSCALL SSL_ERROR_SSL SSL_ERROR_WANT_CONNECT SSL_ERROR_EOF SSL_ERROR_INVALID_ERROR_CODE The following group define certificate requirements that one side is allowing/requiring from the other side: CERT_NONE - no certificates from the other side are required (or will be looked at if provided) CERT_OPTIONAL - certificates are not required, but if provided will be validated, and if validation fails, the connection will also fail CERT_REQUIRED - certificates are required, and will be validated, and if validation fails, the connection will also fail The following constants identify various SSL protocol variants: PROTOCOL_SSLv2 PROTOCOL_SSLv3 PROTOCOL_SSLv23 PROTOCOL_TLS PROTOCOL_TLS_CLIENT PROTOCOL_TLS_SERVER PROTOCOL_TLSv1 PROTOCOL_TLSv1_1 PROTOCOL_TLSv1_2 The following constants identify various SSL alert message descriptions as per http://www.iana.org/assignments/tls-parameters/tls-parameters.xml#tls-parameters-6 ALERT_DESCRIPTION_CLOSE_NOTIFY ALERT_DESCRIPTION_UNEXPECTED_MESSAGE ALERT_DESCRIPTION_BAD_RECORD_MAC ALERT_DESCRIPTION_RECORD_OVERFLOW ALERT_DESCRIPTION_DECOMPRESSION_FAILURE ALERT_DESCRIPTION_HANDSHAKE_FAILURE ALERT_DESCRIPTION_BAD_CERTIFICATE ALERT_DESCRIPTION_UNSUPPORTED_CERTIFICATE ALERT_DESCRIPTION_CERTIFICATE_REVOKED ALERT_DESCRIPTION_CERTIFICATE_EXPIRED ALERT_DESCRIPTION_CERTIFICATE_UNKNOWN ALERT_DESCRIPTION_ILLEGAL_PARAMETER ALERT_DESCRIPTION_UNKNOWN_CA ALERT_DESCRIPTION_ACCESS_DENIED ALERT_DESCRIPTION_DECODE_ERROR ALERT_DESCRIPTION_DECRYPT_ERROR ALERT_DESCRIPTION_PROTOCOL_VERSION ALERT_DESCRIPTION_INSUFFICIENT_SECURITY ALERT_DESCRIPTION_INTERNAL_ERROR ALERT_DESCRIPTION_USER_CANCELLED ALERT_DESCRIPTION_NO_RENEGOTIATION ALERT_DESCRIPTION_UNSUPPORTED_EXTENSION ALERT_DESCRIPTION_CERTIFICATE_UNOBTAINABLE ALERT_DESCRIPTION_UNRECOGNIZED_NAME ALERT_DESCRIPTION_BAD_CERTIFICATE_STATUS_RESPONSE ALERT_DESCRIPTION_BAD_CERTIFICATE_HASH_VALUE ALERT_DESCRIPTION_UNKNOWN_PSK_IDENTITY �N)� namedtuple)�Enum�IntEnum�IntFlag)�OPENSSL_VERSION_NUMBER�OPENSSL_VERSION_INFO�OPENSSL_VERSION)� _SSLContext� MemoryBIO� SSLSession)�SSLError�SSLZeroReturnError�SSLWantReadError�SSLWantWriteError�SSLSyscallError� SSLEOFError�SSLCertVerificationError)�txt2obj�nid2obj)� RAND_status�RAND_add� RAND_bytes�RAND_pseudo_bytes)�RAND_egd) �HAS_SNI�HAS_ECDH�HAS_NPN�HAS_ALPN� HAS_SSLv2� HAS_SSLv3� HAS_TLSv1� HAS_TLSv1_1� HAS_TLSv1_2� HAS_TLSv1_3)�_DEFAULT_CIPHERS�_OPENSSL_API_VERSION� _SSLMethodcCs|�d�o|dkS)NZ PROTOCOL_�PROTOCOL_SSLv23�� startswith��name�r,�/usr/lib64/python3.8/ssl.py�|�r.)�source�OptionscCs |�d�S)NZOP_r(r*r,r,r-r.�r/ZAlertDescriptioncCs |�d�S)NZALERT_DESCRIPTION_r(r*r,r,r-r.�r/ZSSLErrorNumbercCs |�d�S)NZ SSL_ERROR_r(r*r,r,r-r.�r/� VerifyFlagscCs |�d�S)NZVERIFY_r(r*r,r,r-r.�r/� VerifyModecCs |�d�S)NZCERT_r(r*r,r,r-r.�r/cCsi|]\}}||�qSr,r,)�.0r+�valuer,r,r-� �sr6ZPROTOCOL_SSLv2c@s6eZdZejZejZejZ ej Z ej Z ejZejZdS)� TLSVersionN)�__name__� __module__� __qualname__�_sslZPROTO_MINIMUM_SUPPORTEDZMINIMUM_SUPPORTEDZ PROTO_SSLv3�SSLv3Z PROTO_TLSv1ZTLSv1Z PROTO_TLSv1_1ZTLSv1_1Z PROTO_TLSv1_2ZTLSv1_2Z PROTO_TLSv1_3ZTLSv1_3ZPROTO_MAXIMUM_SUPPORTEDZMAXIMUM_SUPPORTEDr,r,r,r-r7�sr7c@s(eZdZdZdZdZdZdZdZdZ dS) �_TLSContentTypez@Content types (record layer) See RFC 8446, section B.1 ������N) r8r9r:�__doc__�CHANGE_CIPHER_SPEC�ALERTZ HANDSHAKEZAPPLICATION_DATA�HEADERZINNER_CONTENT_TYPEr,r,r,r-r=�sr=c@s�eZdZdZdZdZdZdZdZdZ dZ d Z d Z d Z d Zd ZdZdZdZdZdZdZdZdZdZdZdZdZdZdZdZdZdZ dZ!d Z"d!Z#d"Z$d#Z%d$S)%� _TLSAlertTypezQAlert types for TLSContentType.ALERT messages See RFC 8466, section B.2 r� r>r?r@��(�)�*�+�,�-�.�/�0�1�2�3�<�F�G�P�V�Z�d�m�n�o�p�q�r�s�t�xN)&r8r9r:rDZ CLOSE_NOTIFYZUNEXPECTED_MESSAGEZBAD_RECORD_MACZDECRYPTION_FAILEDZRECORD_OVERFLOWZDECOMPRESSION_FAILUREZHANDSHAKE_FAILUREZNO_CERTIFICATEZBAD_CERTIFICATEZUNSUPPORTED_CERTIFICATEZCERTIFICATE_REVOKEDZCERTIFICATE_EXPIREDZCERTIFICATE_UNKNOWNZILLEGAL_PARAMETERZ UNKNOWN_CAZ ACCESS_DENIEDZ DECODE_ERRORZ DECRYPT_ERRORZEXPORT_RESTRICTIONZPROTOCOL_VERSIONZINSUFFICIENT_SECURITYZINTERNAL_ERRORZINAPPROPRIATE_FALLBACKZ USER_CANCELEDZNO_RENEGOTIATIONZMISSING_EXTENSIONZUNSUPPORTED_EXTENSIONZCERTIFICATE_UNOBTAINABLEZUNRECOGNIZED_NAMEZBAD_CERTIFICATE_STATUS_RESPONSEZBAD_CERTIFICATE_HASH_VALUEZUNKNOWN_PSK_IDENTITYZCERTIFICATE_REQUIREDZNO_APPLICATION_PROTOCOLr,r,r,r-rH�sFrHc@sheZdZdZdZdZdZdZdZdZ dZ d Z d Z d Z d Zd ZdZdZdZdZdZdZdZdZdZdZdS)�_TLSMessageTypezFMessage types (handshake protocol) See RFC 8446, section B.3 r�������� � � ���r>r?r@rA��C��rCN)r8r9r:rDZ HELLO_REQUESTZ CLIENT_HELLOZ SERVER_HELLOZHELLO_VERIFY_REQUESTZNEWSESSION_TICKETZEND_OF_EARLY_DATAZHELLO_RETRY_REQUESTZENCRYPTED_EXTENSIONSZ CERTIFICATEZSERVER_KEY_EXCHANGEZCERTIFICATE_REQUESTZ SERVER_DONEZCERTIFICATE_VERIFYZCLIENT_KEY_EXCHANGEZFINISHEDZCERTIFICATE_URLZCERTIFICATE_STATUSZSUPPLEMENTAL_DATAZ KEY_UPDATEZ NEXT_PROTOZ MESSAGE_HASHrEr,r,r,r-rg�s.rg�win32)�enum_certificates� enum_crls)�socket�AF_INET� SOCK_STREAM�create_connection)� SOL_SOCKET�SO_TYPE� tls-unique�HOSTFLAG_NEVER_CHECK_SUBJECTcCs�|sdS|�d�}|s&|��|��kS|dkrsole wildcard without additional labels are not support: {!r}.ztd ||d f��ntd��dS)a�Verify that *cert* (in decoded format as returned by SSLSocket.getpeercert()) matches the *hostname*. RFC 2818 and RFC 6125 rules are followed. The function matches IP addresses rather than dNSNames if hostname is a valid ipaddress string. IPv4 addresses are supported on all platforms. IPv6 addresses are supported on platforms with IPv6 support (AF_INET6 and inet_pton). CertificateError is raised on failure. On success, the function returns nothing. ztempty or no certificate, match_hostname needs a SSL socket or SSL context with either CERT_OPTIONAL or CERT_REQUIREDNZsubjectAltNamer,ZDNSz IP AddressZsubjectZ commonNamerhz&hostname %r doesn't match either of %sz, zhostname %r doesn't match %rrz=no appropriate commonName or subjectAltName fields were found) r�r��getr��appendr��lenr��join�map�repr)�certr�r�ZdnsnamesZsan�keyr5�subr,r,r-�match_hostnamessB         � �r��DefaultVerifyPathszQcafile capath openssl_cafile_env openssl_cafile openssl_capath_env openssl_capathcCsdt��}tj�|d|d�}tj�|d|d�}ttj�|�rF|ndtj�|�rX|ndf|��S)z/Return paths to default cafile and capath. rrhrirjN) r;�get_default_verify_paths�os�environr�r��path�isfile�isdir)�parts�cafile�capathr,r,r-r��s��r�csDeZdZdZdZ�fdd�Ze�fdd��Ze�fdd��Z�Z S) � _ASN1Objectz#ASN.1 object identifier lookup r,cst�j|ft|dd���S)NFr*��super�__new__�_txt2obj)�cls�oid�� __class__r,r-r��sz_ASN1Object.__new__cst�j|ft|���S)z3Create _ASN1Object from OpenSSL numeric ID )r�r��_nid2obj)r�Znidr�r,r-�fromnid�sz_ASN1Object.fromnidcst�j|ft|dd���S)z=Create _ASN1Object from short name, long name or OID Tr*r�)r�r+r�r,r-�fromname�sz_ASN1Object.fromname) r8r9r:rD� __slots__r�� classmethodr�r�� __classcell__r,r,r�r-r��s r�znid shortname longname oidc@seZdZdZdZdZdS)�PurposezDSSLContext purpose flags with X509v3 Extended Key Usage objects z1.3.6.1.5.5.7.3.1z1.3.6.1.5.5.7.3.2N)r8r9r:rD� SERVER_AUTHZ CLIENT_AUTHr,r,r,r-r��sr�cs�eZdZdZdZdZdZefdd�Zdd�Z d2d d �Z d3d d �Z dd�Z dd�Z dd�Zdd�Zejfdd�Zeed�r�e�fdd��Zej�fdd��Ze�fdd��Zej�fdd��Ze�fdd ��Zej�fd!d ��Zeed"��red#d$��Zejd%d$��Zn ed&d$��Ze�fd'd(��Zej�fd)d(��Ze�fd*d+��Ze�fd,d-��Zej�fd.d-��Ze�fd/d0��Zej�fd1d0��Z�Z S)4� SSLContextz|An SSLContext holds various SSL-related configuration options and data, such as certificates and possibly a private key.)ZCAZROOTNcOst�||�}|S�N)r r�)r��protocol�args�kwargs�selfr,r,r-r��s zSSLContext.__new__cCs4|dkr dSt|t�r&|�d��d�S|�d�SdS)NZidna�ascii)� isinstance�str�encode�decode)r�r�r,r,r-�_encode_hostname�s  zSSLContext._encode_hostnameFTc Cs|jj|||||||d�S)N)�sock� server_side�do_handshake_on_connect�suppress_ragged_eofs�server_hostname�context�session)�sslsocket_class�_create)r�r�r�r�r�r�r�r,r,r-� wrap_socket�s�zSSLContext.wrap_socketcCs|jj||||�|�||d�S)N)r�r�r�r�)�sslobject_classr�r�)r��incoming�outgoingr�r�r�r,r,r-�wrap_bio�s�zSSLContext.wrap_biocCs`t�}|D]F}t|d�}t|�dks0t|�dkr8td��|�t|��|�|�q |�|�dS)Nr�r��z(NPN protocols must be 1 to 255 in length)� bytearray�bytesr�r r��extendZ_set_npn_protocols)r�Z npn_protocols�protosr��br,r,r-�set_npn_protocolss  zSSLContext.set_npn_protocolscs8�dkrd�_n$t��s td����fdd�}|�_dS)Nznot a callable objectcs��|�}�|||�Sr�)r�)�sslobjZ servernameZsslctx�r��server_name_callbackr,r-�shim_cbs z3SSLContext.set_servername_callback..shim_cb)Z sni_callback�callable� TypeError)r�r�r�r,r�r-�set_servername_callbacks z"SSLContext.set_servername_callbackcCs`t�}|D]F}t|d�}t|�dks0t|�dkr8td��|�t|��|�|�q |�|�dS)Nr�rr�z)ALPN protocols must be 1 to 255 in length)r�r�r�r r�r�Z_set_alpn_protocols)r�Zalpn_protocolsr�r�r�r,r,r-�set_alpn_protocols s  zSSLContext.set_alpn_protocolscCsvt�}z.inner)r�r�r�r��hasattrr�r�)r�rr�r�rr-r��s  cs tt�j�Sr�)r&r�r�r�r�r,r-r��szSSLContext.protocolcs tt�j�Sr�)r2r�� verify_flagsr�r�r,r-r�szSSLContext.verify_flagscsttt�j�||�dSr�)r�r�rr�r�r�r,r-r�scs0t�j}z t|�WStk r*|YSXdSr�)r�� verify_moder3r�r�r�r,r-r�s  zSSLContext.verify_modecsttt�j�||�dSr�)r�r�rr�r�r�r,r-r�s)FTTNN)FNN)!r8r9r:rDr�r�r�� PROTOCOL_TLSr�r�r�r�r�r�r�r�r�r�r�rr �propertyr��setterr�r�r;r�r�r�rrr�r,r,r�r-r��sn � �         &%r�)r�r�r�cCs�t|t�st|��tt�}|tjkr0t|_d|_ |s<|s<|rL|� |||�n|jt kr`|� |�t |d�r�tj�d�}|r�tjjs�||_|S)z�Create a SSLContext object with default settings. NOTE: The protocol and settings may change anytime without prior deprecation. The values represent a fair balance between maximum compatibility and security. T�keylog_filename� SSLKEYLOGFILE)r�r�r�r�rr�r�� CERT_REQUIREDr�check_hostnamer�� CERT_NONEr�rr�r�r�r��flags�ignore_environmentr)r�r�r�r�r�� keylogfiler,r,r-�create_default_context�s        rF)� cert_reqsr r��certfile�keyfiler�r�r�c Cs�t|t�st|��t|�} |s$d| _|dk r2|| _|r�Z"ed?d@��Z#�fdAdB�Z$edCdD��Z%edEdF��Z&�fdGdH�Z'edddIdJ��Z(�fdKdL�Z)dMdN�Z*dOdP�Z+�fdQdR�Z,ededTdU��Z-edVdW��Z.�Z/S)f� SSLSocketz�This class implements a subtype of socket.socket that wraps the underlying OS socket in an SSL context when necessary, and provides read and write methods over that channel. cOst|jj�d���dS)NzX does not have a public constructor. Instances are returned by SSLContext.wrap_socket().rrr,r,r-r�s �zSSLSocket.__init__FTNc s�|�tt�tkrtd��|r8|r(td��|dk r8td��|jrJ|sJtd��t|j|j |j |� �d�}|j |f|�} t t| �jf|�| �|���|��|| _|| _d| _d| _|| _|�|�| _|| _|| _z | ��Wn6tk �r} z| jtjkr��d} W5d} ~ XYnXd} | | _ | �r�zH| jj!| || j| | jd�| _|�rj| ��} | d k�rbtd ��| �"�Wn$ttfk �r�| �#��YnX| S) Nz!only stream sockets are supportedz4server_hostname can only be specified in client modez,session can only be specified in client modez'check_hostname requires server_hostname)�family�type�proto�filenoFT�rr��zHdo_handshake_on_connect should not be specified for non-blocking sockets)$Z getsockoptrr�r}�NotImplementedErrorr�r �dictr<r=r>r?r�r�r;r� settimeout� gettimeout�detach�_context�_sessionZ_closedrr�r�r�r�r�� getpeernamer��errnoZENOTCONN� _connected� _wrap_socketr1�close) r�r�r�r�r�r�r�r�r�r��eZ connected�timeoutr�r,r-r��sj �   �  zSSLSocket._createcCs|jSr�)rGr�r,r,r-r�szSSLSocket.contextcCs||_||j_dSr�)rGrr�rr,r,r-r�scCs|jdk r|jjSdSr�rr�r,r,r-r� s zSSLSocket.sessioncCs||_|jdk r||j_dSr�)rHrr�r r,r,r-r�&s cCs|jdk r|jjSdSr�r!r�r,r,r-r",s zSSLSocket.session_reusedcCstd|jj��dS)NzCan't dup() %s instances)rBr�r8r�r,r,r-�dup2s�z SSLSocket.dupcCsdSr�r,)r��msgr,r,r-� _checkClosed6szSSLSocket._checkClosedcCs|js|��dSr�)rKrIr�r,r,r-�_check_connected:szSSLSocket._check_connectedr#c Cs�|��|jdkrtd��z*|dk r4|j�||�WS|j�|�WSWnVtk r�}z8|jdtkr�|jr�|dk r|WY�dSWY� dSn�W5d}~XYnXdS)zORead up to LEN bytes and return them. Return zero-length string on EOF.Nz'Read on closed or unwrapped SSL socket.rr/)rRrr�r$r r�Z SSL_ERROR_EOFr�)r�r�r%�xr,r,r-r$Bs   zSSLSocket.readcCs&|��|jdkrtd��|j�|�S)zhWrite DATA to the underlying SSL channel. Returns number of bytes of DATA actually transmitted.Nz(Write on closed or unwrapped SSL socket.)rRrr�r'r(r,r,r-r'Ws zSSLSocket.writecCs|��|��|j�|�Sr�)rRrSrr)r*r,r,r-r)`szSSLSocket.getpeercertcCs*|��|jdkstjsdS|j��SdSr�)rRrr;rr+r�r,r,r-r+fszSSLSocket.selected_npn_protocolcCs*|��|jdkstjsdS|j��SdSr�)rRrr;rr,r�r,r,r-r,nsz SSLSocket.selected_alpn_protocolcCs$|��|jdkrdS|j��SdSr�)rRrr-r�r,r,r-r-vs zSSLSocket.ciphercCs$|��|jdkrdS|j��SdSr�)rRrr.r�r,r,r-r.~s zSSLSocket.shared_cipherscCs$|��|jdkrdS|j��SdSr�)rRrr/r�r,r,r-r/�s zSSLSocket.compressionrcsF|��|jdk r4|dkr(td|j��|j�|�St��||�SdS)Nrz3non-zero flags not allowed in calls to send() on %s)rRrr�r�r'r��send)r�r�r r�r,r-rU�s �� zSSLSocket.sendcsL|��|jdk r"td|j��n&|dkr8t��||�St��|||�SdS)Nz%sendto not allowed on instances of %s)rRrr�r�r��sendto)r�r�Z flags_or_addrr�r�r,r-rV�s �zSSLSocket.sendtocOstd|j��dS)Nz&sendmsg not allowed on instances of %s�rBr�rr,r,r-�sendmsg�s�zSSLSocket.sendmsgc s�|��|jdk r�|dkr(td|j��d}t|��H}|�d��2}t|�}||krn|�||d��}||7}qJW5QRXW5QRXnt�� ||�SdS)Nrz6non-zero flags not allowed in calls to sendall() on %s�B) rRrr�r�� memoryview�castr�rUr��sendall)r�r�r r�ZviewZ byte_viewZamountr&r�r,r-r\�s �� zSSLSocket.sendallcs,|jdk r|�|||�St��|||�SdS)z�Send a file, possibly by using os.sendfile() if this is a clear-text socket. Return the total number of bytes sent. N)rZ_sendfile_use_sendr��sendfile)r��file�offsetr�r�r,r-r]�s zSSLSocket.sendfilecsD|��|jdk r2|dkr(td|j��|�|�St��||�SdS)Nrz3non-zero flags not allowed in calls to recv() on %s)rRrr�r�r$r��recv�r�Zbuflenr r�r,r-r`�s �� zSSLSocket.recvcsj|��|r|dkrt|�}n |dkr*d}|jdk rV|dkrJtd|j��|�||�St��|||�SdS)Nr#rz8non-zero flags not allowed in calls to recv_into() on %s)rRr�rr�r�r$r�� recv_into�r�r%�nbytesr r�r,r-rb�s   �� zSSLSocket.recv_intocs4|��|jdk r"td|j��nt��||�SdS)Nz'recvfrom not allowed on instances of %s)rRrr�r�r��recvfromrar�r,r-re�s  �zSSLSocket.recvfromcs6|��|jdk r"td|j��nt��|||�SdS)Nz,recvfrom_into not allowed on instances of %s)rRrr�r�r�� recvfrom_intorcr�r,r-rf�s  �zSSLSocket.recvfrom_intocOstd|j��dS)Nz&recvmsg not allowed on instances of %srWrr,r,r-�recvmsg�s�zSSLSocket.recvmsgcOstd|j��dS)Nz+recvmsg_into not allowed on instances of %srWrr,r,r-� recvmsg_into�s�zSSLSocket.recvmsg_intocCs$|��|jdk r|j��SdSdS)Nr)rRrr0r�r,r,r-r0�s  zSSLSocket.pendingcs|��d|_t��|�dSr�)rRrr�r2)r�Zhowr�r,r-r2�szSSLSocket.shutdowncCs.|jr|j��}d|_|Stdt|���dS�NzNo SSL wrapper around )rr2r�r�)r��sr,r,r-r3s  zSSLSocket.unwrapcCs$|jr|j��Stdt|���dSri)rr7r�r�r�r,r,r-r7 s z&SSLSocket.verify_client_post_handshakecsd|_t���dSr�)rr�� _real_closer�r�r,r-rkszSSLSocket._real_closec CsF|��|��}z$|dkr(|r(|�d�|j��W5|�|�XdS)NrA)rSrErDrr1)r��blockrOr,r,r-r1s  zSSLSocket.do_handshakec s�|jrtd��|js|jdk r&td��|jj|d|j||jd�|_z@|rVt�� |�}nd}t�� |�|s~d|_|j r~|� �|WSt tfk r�d|_�YnXdS)Nz!can't connect in server-side modez/attempt to connect already-connected SSLSocket!Fr@T)r�r�rKrr�rLr�rHr�� connect_ex�connectr�r1r�)r�r�rmZrcr�r,r-� _real_connect!s0� zSSLSocket._real_connectcCs|�|d�dS)�QConnects to remote ADDR, and then wraps the connection in an SSL channel.FN�ro�r�r�r,r,r-rn;szSSLSocket.connectcCs |�|d�S)rpTrqrrr,r,r-rm@szSSLSocket.connect_excs.t���\}}|jj||j|jdd�}||fS)z�Accepts a new connection from a remote client, and returns a tuple containing that new connection wrapped with a server-side SSL channel, and the address of the remote client.T)r�r�r�)r��acceptr�r�r�r�)r�Znewsockr�r�r,r-rsEs�zSSLSocket.acceptr�cCs4|jdk r|j�|�S|tkr,td�|���dSdS)Nz({0} channel binding type not implemented)rr4�CHANNEL_BINDING_TYPESr�r�r5r,r,r-r4Qs  �zSSLSocket.get_channel_bindingcCs|jdk r|j��SdSdSr�r6r�r,r,r-r�\s  zSSLSocket.version)FTTNNN)N)r#N)F)r)N)r)rN)r#r)Nr)r#r)Nr)F)r�)0r8r9r:rDrr�r�rr:r�rr�r"rPrRrSr$r'r)r+r,r-r.r/rUrVrXr\r]r`rbrerfrgrhr0r2r3r7rkr1rornrmrsr4r�r�r,r,r�r-r;�s��>                          r;Tc Csl|r|std��|r |s td��t|�} || _|r<| �|�|rL| �||�| rZ| �| �| j||||d�S)Nz5certfile must be specified for server-side operationsr)r�r�r�r�)r�r�rr�rZ set_ciphersr�) r�rrr�r� ssl_version�ca_certsr�r�Zciphersr�r,r,r-r�is$   �r�cCs�ddlm}ddlm}d}d}z|�|dd����d}Wn$tk rbtd ||f��Yn0X||dd�|�}||d|f|d d ��SdS) a�Return the time in seconds since the Epoch, given the timestring representing the "notBefore" or "notAfter" date from a certificate in ``"%b %d %H:%M:%S %Y %Z"`` strptime format (C locale). "notBefore" or "notAfter" dates must use UTC (RFC 5280). Month is one of: Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec UTC should be specified as GMT (see ASN1_TIME_print()) r)�strptime)�timegm) ZJanZFebZMarZAprZMayZJunZJulZAugZSepZOctZNovZDecz %d %H:%M:%S %Y GMTNrjrhz*time data %r does not match format "%%b%s"rirm)�timerwZcalendarrx�index�titler�)Z cert_timerwrxZmonthsZ time_formatZ month_numberZttr,r,r-�cert_time_to_seconds�s  � r|z-----BEGIN CERTIFICATE-----z-----END CERTIFICATE-----csRtt�|�dd��tg}|�fdd�tdt��d�D�7}|�td�d�|�S)z[Takes a certificate in binary DER format and returns the PEM version of it as a string.�ASCII�strictcsg|]}�||d��qS)�@r,)r4�i��fr,r-� �sz(DER_cert_to_PEM_cert..rr� ) r��base64Zstandard_b64encode� PEM_HEADER�ranger�r�� PEM_FOOTERr�)Zder_cert_bytesZssr,r�r-�DER_cert_to_PEM_cert�s "r�cCs\|�t�stdt��|���t�s0tdt��|��tt�tt� �}t�|� dd��S)zhTakes a certificate in ASCII PEM format and returns the DER-encoded version of it as a byte sequencez(Invalid PEM encoding; must start with %sz&Invalid PEM encoding; must end with %sr}r~) r)r�r��strip�endswithr�r�r�Z decodebytesr�)Zpem_cert_string�dr,r,r-�PEM_cert_to_DER_cert�s ��r�c Csd|\}}|dk rt}nt}t|||d�}t|��&}|�|��}|�d�} W5QRXW5QRXt| �S)z�Retrieve the certificate from the server at the specified address, and return it as a PEM-encoded string. If 'ca_certs' is specified, validate the server cert against it. If 'ssl_version' is specified, use it in the connection attempt.N)rr�T)r r �_create_stdlib_contextr~r�r)r�) r�rurvZhostZportrr�r�ZsslsockZdercertr,r,r-�get_server_certificate�s�  r�cCs t�|d�S)Nz )�_PROTOCOL_NAMESr�)Z protocol_coder,r,r-�get_protocol_name�sr�)nrDr�r�� collectionsr�enumrZ_EnumrZ_IntEnumrZ_IntFlagr;rrrr r r r r rrrrrrr�rr�rrrrr� ImportErrorrrrrrrr r!r"r#r$r%� _convert_r8r&rr'� __members__�itemsr�r8Z_SSLv2_IF_EXISTSr7r=rHrgr�ryrzr{r|r}r~rr�r�r�rJr�r�Z socket_errorrtrZHAS_NEVER_CHECK_COMMON_NAMEZ_RESTRICTED_SERVER_CIPHERSr�r�r�r�r�r�r�r�r�r�r�rr rZ_create_default_https_contextr�rr:r;r�r�r�r|r�r�r�r�r�r�r,r,r,r-�s�Y $0������   )  1# 9�z� #� /�