U e5d�:�@sldZddlZddlZddlZddlZzddlZdZWnek rLdZYnXddgZGdd�de �Z dZ d Z d Z d Ze eZd ZGd d�d�Zer�Gdd�de�Ze�d�edk�rhddlZeejd�Zee���e�ejd�e�ejd�e��e��\ZZeded�D]BZ e�!e �\Z"Z#Z$ede �e#D]Z%ede%��q@ed��qe�&�dS)z@A POP3 client class. Based on the J. Myers POP3 draft, Jan. 96 �NTF�POP3� error_protoc@s eZdZdS)rN)�__name__� __module__� __qualname__�rr�/usr/lib64/python3.8/poplib.pyrs�ni�� � ic@s eZdZdZdZeejfdd�Zdd�Z dd�Z d d �Z d d �Z d d�Z dd�Zdd�Zdd�Zdd�Zdd�Zdd�Zdd�Zdd�Zd=d d!�Zd"d#�Zd$d%�Zd&d'�Zd(d)�Zd*d+�Zd,d-�Zd.d/�Ze�d0�Z d1d2�Z!d3d4�Z"d>d5d6�Z#d7d8�Z$d9d:�Z%d?d;d<�Z&dS)@raPThis class supports both the minimal and optional command sets. Arguments can be strings or integers (where appropriate) (e.g.: retr(1) and retr('1') both work equally well. Minimal Command Set: USER name user(name) PASS string pass_(string) STAT stat() LIST [msg] list(msg = None) RETR msg retr(msg) DELE msg dele(msg) NOOP noop() RSET rset() QUIT quit() Optional Commands (some servers support these): RPOP name rpop(name) APOP name digest apop(name, digest) TOP msg n top(msg, n) UIDL [msg] uidl(msg = None) CAPA capa() STLS stls() UTF8 utf8() Raises one exception: 'error_proto'. Instantiate with: POP3(hostname, port=110) NB: the POP protocol locks the mailbox from user authorization until QUIT, so be sure to get in, suck the messages, and quit, each time you access the mailbox. POP is a line-based protocol, which means large mail messages consume lots of python cycles reading them line-by-line. If it's available on your mail server, use IMAP4 instead, it doesn't suffer from the two problems above. zUTF-8cCsP||_||_d|_t�d|||�|�|�|_|j�d�|_d|_ |� �|_ dS)NFzpoplib.connect�rbr) �host�port�_tls_established�sys�audit�_create_socket�sock�makefile�file� _debugging�_getresp�welcome)�selfr r�timeoutrrr�__init__bs z POP3.__init__cCst�|j|jf|�S�N)�socketZcreate_connectionr r)rrrrrrmszPOP3._create_socketcCs:|jdkrtdt|��t�d||�|j�|t�dS)N�z*put*zpoplib.putline)r�print�reprrrrZsendall�CRLF�r�linerrr�_putlineps z POP3._putlinecCs.|jrtdt|��t||j�}|�|�dS)Nz*cmd*)rrr �bytes�encodingr$r"rrr�_putcmdxs z POP3._putcmdcCs�|j�td�}t|�tkr$td��|jdkr)rZpswdrrr�pass_�sz POP3.pass_cCsF|�d�}|��}|jr&tdt|��t|d�}t|d�}||fS)z]Get mailbox status. Result is tuple of 2 ints (message count, mailbox size) ZSTATz*stat*r�)r8�splitrrr �int)rZretvalZretsZ numMessagesZ sizeMessagesrrr�stat�s   z POP3.statNcCs |dk r|�d|�S|�d�S)aRequest listing, return result. Result without a message number argument is in form ['response', ['mesg_num octets', ...], octets]. Result when a message number argument is given is a single response: the "scan listing" for that message. NzLIST %sZLIST�r8r9�r�whichrrrr6�s z POP3.listcCs|�d|�S)zoRetrieve whole message number 'which'. Result is in form ['response', ['line', ...], octets]. zRETR %s�r9rGrrr�retr�sz POP3.retrcCs|�d|�S)zFDelete message number 'which'. Result is 'response'. zDELE %sr>rGrrr�dele�sz POP3.delecCs |�d�S)zXDoes nothing. One supposes the response indicates the server is alive. ZNOOPr>r:rrr�noopsz POP3.noopcCs |�d�S)z(Unmark all messages marked for deletion.ZRSETr>r:rrr�rsetsz POP3.rsetcCs|�d�}|��|S)zDSignoff: commit changes on server, unlock mailbox, close connection.ZQUIT)r8�close)rr2rrr�quits z POP3.quitcCs�z |j }d|_ |dk r|��W5|j}d|_|dk r�zVz|�tj�Wn@tk r�}z"|jtjkrxt|dd�dkrx�W5d}~XYnXW5|��XXdS)z8Close the connection without assuming anything about it.NZwinerrorri&') rrNZshutdownrZ SHUT_RDWR�OSError�errnoZENOTCONN�getattrr)rr�excrrrrrNs   �z POP3.closecCs|�d|�S)zNot sure what this does.zRPOP %sr>r?rrr�rpop5sz POP3.rpops\+OK.[^<]*(<.*>)cCs\t||j�}|j�|j�}|s&td��ddl}|�d�|}|�|�� �}|� d||f�S)a Authorisation - only possible if server has supplied a timestamp in initial greeting. Args: user - mailbox user; password - mailbox password. NB: mailbox is locked by server from here to 'quit()' z!-ERR APOP not supported by serverrNrz APOP %s %s) r%r&� timestamp�matchrr�hashlib�groupZmd5Z hexdigestr8)rr@ZpasswordZsecret�mrWZdigestrrr�apop<s z POP3.apopcCs|�d||f�S)z�Retrieve message header of message number 'which' and first 'howmuch' lines of message body. Result is in form ['response', ['line', ...], octets]. z TOP %s %srI)rrHZhowmuchrrr�topQszPOP3.topcCs |dk r|�d|�S|�d�S)z�Return message digest (unique id) list. If 'which', result contains unique id for that message in the form 'response mesgnum uid', otherwise result is the list ['response', ['mesgnum uid', ...], octets] NzUIDL %sZUIDLrFrGrrr�uidlZsz POP3.uidlcCs |�d�S)zITry to enter UTF-8 mode (see RFC 6856). Returns server response. ZUTF8r>r:rrr�utf8fsz POP3.utf8c Cspdd�}i}z4|�d�}|d}|D]}||�\}}|||<q$Wn*tk rj}z td��W5d}~XYnX|S)aReturn server capabilities (RFC 2449) as a dictionary >>> c=poplib.POP3('localhost') >>> c.capa() {'IMPLEMENTATION': ['Cyrus', 'POP3', 'server', 'v2.2.12'], 'TOP': [], 'LOGIN-DELAY': ['0'], 'AUTH-RESP-CODE': [], 'EXPIRE': ['NEVER'], 'USER': [], 'STLS': [], 'PIPELINING': [], 'UIDL': [], 'RESP-CODES': []} >>> Really, according to RFC 2449, the cyrus folks should avoid having the implementation split into multiple arguments... cSs"|�d���}|d|dd�fS)N�asciirr)�decoderC)r#Zlstrrr� _parsecapyszPOP3.capa.._parsecapZCAPArz!-ERR CAPA not supported by serverN)r9r) rr`�capsr2ZrawcapsZcaplineZcapnmZcapargsZ_errrrr�capals   z POP3.capacCsxts td��|jrtd��|��}d|kr2td��|dkrBt��}|�d�}|j|j|j d�|_|j� d�|_ d|_|S) z{Start a TLS session on the active connection as specified in RFC 2595. context - a ssl.SSLContext z-ERR TLS support missing�$-ERR TLS session already establishedZSTLSz!-ERR STLS not supported by serverN�Zserver_hostnamer T) �HAVE_SSLrrrb�ssl�_create_stdlib_contextr8� wrap_socketrr rr)r�contextrar2rrr�stls�s  �z POP3.stls)N)N)N)'rrr�__doc__r&� POP3_PORTr�_GLOBAL_DEFAULT_TIMEOUTrrr$r'r/rr7r8r9r;r=r@rArEr6rJrKrLrMrOrNrT�re�compilerUrZr[r\r]rbrjrrrrr3sB+�       c@s8eZdZdZeddejdfdd�Zdd�Zd dd�Z dS) �POP3_SSLaPOP3 client class over SSL connection Instantiate with: POP3_SSL(hostname, port=995, keyfile=None, certfile=None, context=None) hostname - the hostname of the pop3 over ssl server port - port number keyfile - PEM formatted file that contains your private key certfile - PEM formatted certificate chain file context - a ssl.SSLContext See the methods of the parent class POP3 for more documentation. NcCs�|dk r|dk rtd��|dk r0|dk r0td��|dk s@|dk rVddl}|�dtd�||_||_|dkrxtj||d�}||_t � ||||�dS)Nz4context and keyfile arguments are mutually exclusivez5context and certfile arguments are mutually exclusiverzAkeyfile and certfile are deprecated, use a custom context insteadrB)�certfile�keyfile) � ValueError�warnings�warn�DeprecationWarningrrrqrfrgrirr)rr rrrrqrrirtrrrr�s$��zPOP3_SSL.__init__cCs"t�||�}|jj||jd�}|S)Nrd)rrrirhr )rrrrrrr�s  �zPOP3_SSL._create_socketcCs td��dS)z�The method unconditionally raises an exception since the STLS command doesn't make any sense on an already established SSL/TLS session. rcN)r)rrrrqrirrrrj�sz POP3_SSL.stls)NNN) rrrrk� POP3_SSL_PORTrrmrrrjrrrrrp�s� rp�__main__rrB�z Message %d:z z-----------------------)'rkrQrnrrrfre� ImportError�__all__� Exceptionrrlrwr-ZLFr!r+rrpr5r�argv�arr;r@rAr6rEZnumMsgsZ totalSize�range�irJ�header�msgr.r#rOrrrr�sL n0